
 

 

 5.4 Customized plugin tool 

 

5.4.1 PTHA Based Tsunami Inundation Tool 

It is a QGIS Processing plugin for generating tsunami inundation zones using Probabilistic Tsunami 

Hazard Assessment (PTHA) water levels and coastal Digital Elevation Models (DEM). This tool 

automates tsunami hazard mapping by combining offshore PTHA water level estimates with coastal 

terrain elevation to identify areas potentially affected by tsunami inundation. 

1. Data Source 

• This plugin utilizes Probabilistic Tsunami Hazard Assessment (PTHA) point data and 

associated water level estimates derived using the methodology and tools developed by 

Geoscience Australia. 

• The original PTHA modelling framework and access tools are available at: 

https://github.com/GeoscienceAustralia/ptha/tree/master/ptha_access 

• Users are encouraged to refer to the original repository and associated documentation for 

details regarding the methodology, assumptions, and limitations of the PTHA datasets. 

 

2. Important Disclaimer 

• This plugin provides a simplified workflow to visualize potential tsunami inundation zones 

using pre-generated PTHA point data and user-supplied elevation models. The plugin does not 

perform tsunami simulations or probabilistic hazard calculations itself. 

• The developers of this plugin do not generate, validate, or modify the underlying PTHA hazard 

data, and therefore assume no responsibility for the accuracy, completeness, or applicability 

of the results produced using this tool. 

• Outputs generated by this plugin are intended for research, educational, and exploratory 

purposes only and must not be used for operational decision-making, hazard forecasting, 

emergency response planning, or regulatory applications without independent verification 

and expert review. 

• Users are solely responsible for evaluating the suitability of the input datasets and 

interpreting the results produced by this tool. 

 

3. Installation 

• Open QGIS → Plugins → Manage and Install Plugins → Select the "All" tab → Search for PTHA 

Based Tsunami Inundation Tool → Install the plugin. 

 

https://github.com/GeoscienceAustralia/ptha/tree/master/ptha_access


 

 
 

4. Open the DEM into QGIS 

• Add DEM to QGIS by clicking Layer --> Add Layer --> Add Raster Layer 

 

 
 



 

• Click on Browser icon  and select DEM directory and select DEM file.  

 

 
 

5. Open Plugin  

• Open Processing toolbox 

 

 
 

• Search 'PTHA Based Tsunami Inundation' tool --> Open it. 



 
6. Input parameters:  

• Select DEM. 

• Use Layer extent if Village/Town Polygon layer is available, else draw extent of map by 

clicking dropdown arrow in Area of Interest field (Area if interst should be within DEM 

extent). 

• Choose return period 

• Set Stage Estimation Type 

• Run 

 



7. Output  

• After successful run, Hazard layer is addeed in Map window (of your area of interest). 

 

 
 

8. Methodological Limitations  

• The tsunami hazard zones generated by this plugin are based on a simplified inundation mapping 

approach using precomputed Probabilistic Tsunami Hazard Assessment (PTHA) water levels and a 

user-provided Digital Elevation Model (DEM). The following limitations should be considered 

when interpreting the results: 

i. Bathtub Inundation Approach The inundation extent is estimated using a static 

bathtub method, where terrain elevation is compared with tsunami water levels. This 

approach does not simulate dynamic hydrodynamic processes such as wave 

propagation, run-up, flow velocity, or inland flow routing. 

ii. Nearest-Point Water Level Approximation Tsunami water levels are obtained from 

the nearest available PTHA point. This may not capture spatial variations in tsunami 

wave heights along complex coastlines or within bays and estuaries. 

iii. DEM Resolution and Vertical Accuracy The accuracy of inundation results depends 

strongly on the spatial resolution and vertical accuracy of the input DEM. Errors or 

coarse resolution in elevation data may significantly influence the predicted 

inundation extent. 

iv. Simplified Coastal Connectivity The method does not explicitly model hydraulic 

connectivity between the ocean and inland areas. Depending on terrain 

characteristics, isolated low-lying depressions may be incorrectly classified as 

inundated. 

v. No Tsunami Propagation Modeling This plugin does not perform tsunami generation, 

propagation, or wave transformation modelling. It only visualizes potential 

inundation extents based on externally generated tsunami water level estimates. 



• Outputs generated using this tool are intended primarily for research, visualization, and 

exploratory hazard assessment purposes. They should not be used for operational forecasting, 

emergency response planning, or regulatory decision-making without further detailed analysis 

and expert validation. 

9. Important Note  

• The tsunami stage values used in this plugin are derived from the PTHA dataset 

developed by Geoscience Australia. These values represent tsunami maximum stage 

estimates at offshore points. 

• Nearshore hazard points should be interpreted only as an approximate indication of 

potential tsunami wave heights. They are not intended to directly force detailed 

inundation models. Accurate tsunami inundation modelling typically requires high-

resolution hydrodynamic simulations that account for wave propagation, coastal 

bathymetry, topography, and flow dynamics. 

• Therefore, the inundation zones generated by this plugin should be 

considered screening-level or exploratory hazard estimates rather than physically 

simulated tsunami inundation extents. For detailed hazard assessment and operational 

applications, dedicated tsunami modelling frameworks should be used. 

• Users are encouraged to consult the original PTHA dataset documentation for further 

details regarding model assumptions, uncertainty treatment, and appropriate usage. 
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https://github.com/GeoscienceAustralia/ptha


5.4.2 Downloading Building data  

1. Downloading Building Footprints (Open Buildings V3) 

The Open Buildings V3 dataset contains 1.8 billion building detections across an inference 

area of 58 million km², covering Africa, South Asia, South-East Asia, Latin America, and the 

Caribbean. 

Building footprint data derived from the Google Open Buildings dataset (v3), © Google, 

licensed under CC BY 4.0. 

 

 

 

 

 

 

2. Downloading Google Open Building Data is available at: 

https://sites.research.google/gr/open-buildings/ 

 

 
• Click on the "Download here" button. You can search your Area of Interest (AOI) or 

zoom into your area and select the required tile. 

Important Notes Regarding Open Buildings Dataset: 

• AI-derived dataset 

• May miss small or rural structures 

• Includes confidence scores 

• Should NOT be treated as cadastral or legal boundary data 

 

https://sites.research.google/gr/open-buildings/


 
 

• Download the file named: xxx_buildings.csv.gz 

• After downloading, extract the file to obtain the CSV file. 

 

3. Adding Building Data into QGIS 

• Open QGIS. 

• Navigate to: Layer → Add Layer → Add Delimited Text Layer 

 

 
• Configure Layer Settings: 

o Select the extracted CSV file 

o Under Geometry Definition, choose Well Known Text (WKT) 

o Select geometry in Geometry field 

o Set Geometry CRS to EPSG:4326 – WGS84 

o Click Add 

 

 



 

 

 
 

4. Selecting Area of Interest (AOI) 

• Activate the Select Features Tool 

• Draw a polygon over your Area of Interest 

 

Note 

 

This step may take considerable time as the dataset may contain more than 10 million 

building footprints. 

 



 
5. Export Selected Buildings 

• Right-click the building layer in the Layer Panel 

• Select Export → Export Selected Features As 

• Save the file as Shapefile (.shp) 

 

 



 
 

• Selected buildings will be saved in new layer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5.4.3 Building level tsunami evacuation planning  

 

We will install Build_Short_Evac_Time, a QGIS plugin designed to automatically identify buildings requiring 

evacuation within a tsunami-affected area and generate the shortest evacuation routes to designated safe 

shelters using minimal user input. 

GitHub Repository: https://github.com/gauravbkhairnar/Build_Short_Evac_Time_QGIS_Plugin 

This plugin requires prerequisites. Please complete the following steps before installing the plugin. 

1. Installing Prerequisites: 

• Download the requirements.txt file. 

• For Windows: 

o Copy the requirements.txt file path 

o Open Start → OSGeo4W Shell 

o Navigate to the file location using: 

cd <paste file path> 

o Run this command: pip install -r requirements.txt 

 

• For Linux: 

o Open Terminal 

o Navigate to the file location: 

o cd <requirements file path> 

o Run this command: python3 -m pip install --user -r requirements.txt 

 

• Restart QGIS after installation 

 

2. Installing the Plugin 

• Open QGIS → Plugins → Manage and Install Plugins → Select the "All" tab → Search 

for Build_Short_Evac_Time → Install the plugin. 

 

https://github.com/gauravbkhairnar/Build_Short_Evac_Time_QGIS_Plugin
https://indiannational-my.sharepoint.com/:t:/g/personal/gb_khairnar-p_incois_gov_in/IQAjMkcNdlQUT6O7jB9G4z1FAdqugvRDl9Xh44rVVSDPzgY?e=o2PuOq


 
3. Input requirements 

• The first three datasets must be vector layers in one of the following supported 

formats: 

o Shapefile (.shp) 

o GeoJSON (.geojson) 

• The optional Digital Elevation Model (DEM) must be in .tif format. 

• Required Layers: 

o Building Layer (Geometry: Polygon) 

o Evacuation Shelters Layer (Geometry: Point) 

o Flood Inundation Layer (Geometry: Polygon) 

o (Optional) Digital Elevation Model (Raster: TIFF) 

 

4. Building-Level Evacuation Analysis 

• After successful installation, navigate to: QGIS → Plugins → Build_Short_Evac_Time 

→ Build Shortest Evacuation Time. 

 

 
• Select Input Layers 

o If the Building, Evacuation Shelter, and Flood Inundation layers are already 

loaded in the QGIS Layers Panel, select them using the dropdown menus. 



o Alternatively, use the Browse buttons to select input layers directly from disk. 

o Uploading DEM is optional. If provided, terrain slope will be incorporated into 

walking time calculation for more realistic results. If not provided, terrain is 

assumed to be flat. 

• Select Output folder (optional) 

o Specify an output folder to save results. 

o If no folder is provided, temporary memory layers will be created 

automatically. 

• Run the model 

 

 
 

5. Output 

 

• After successful execution, the following layers will be added to the QGIS Layers 

Panel: 

i. buildings_with_clusters 

o Contains buildings identified as requiring evacuation 

o Includes building-level evacuation attributes 

ii. Evacuation_Routes 

o Represents the shortest walking routes from each building to its assigned 

evacuation shelter 

• Output Attributes: 

o Each building is assigned to the nearest evacuation shelter and that shelter’s ID 

and the shortest route is computed between each building and its assigned 

shelter. 

o Walking time is calculated and stored in the Time field from the building to the 

shelter. 



     
 

6. Assumptions 

• Evacuation is assumed to occur by walking to avoid traffic congestion 

• All evacuees are assumed to be physically fit adults and walking speed is considered 

as 5 m/s 

• Road network derived from OpenStreetMap is assumed to be fully passable. Off-road 

evacuation is not considered 

• All evacuees are assumed to start from the nearest accessible node/junction on the 

road network. The distance from each building to the nearest junction and the 

walking time within the building (in case of a big building/multi-story) are not 

considered. 

 

7. Exceptions and Special Conditions 

• No Buildings in Flood Zone: If no buildings intersect with the flood inundation zone, 

the process terminates automatically and a message is displayed: “No Buildings in 

the Flood Zone” 

• All Shelters Within Flood Zone: If all evacuation shelters fall within the 

flooding/inundation area, the process terminates and the following message is 

shown: “All evacuation shelters are in the flood zone”. 

• If no OpenStreetMap (OSM) pedestrian road network is found in the vicinity of the 

buildings the process stops and a warning message is displayed: “Road Network Not 

Found”. 

 

 

 

 

 

Important Notes: 

 

The model executes using sequential processing; parallel processing is not implemented. 

Sample datasets are available in the sample data folder for testing and demonstration. 

 

https://github.com/gauravbkhairnar/Build_Short_Evac_Time_QGIS_Plugin/tree/main/sample_data
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